Transactions transferring FOAM from MetaMask failing


#1

I completed POU a couple days ago and want to move my tokens to a different address. Every time I do this, even with more gas than needed, it fails. Not sure why/how this is happening than maybe the contract not acknowledging my POU?

Thanks


#2

The solution is simple, albeit confusing, so apologies for that. I am trying to find the section on our blog/guide that addresses this but in the meantime:

In order to “finalize” Proof of Use one transaction of any amount of FOAM needs to be made to another wallet while Proof of Use is complete. This means that while you have tokens Signaled and the modal says it is complete you need to make one transaction while your tokens are still in the Signal.

After this proof of use will be “finalized” and you can withdraw from the Signal and transfer those tokens. Once it is “finalized” it is over completely. In your case since you did not do this “finalization” step the Token Controller interprets that you have not completed Proof of Use.

To rephrase Signal or add Points once more so the modal says that you have completed PoU, then make one transfer from you address to another wallet. This “latches” shut PoU but needs to be done while you have passed it.

I hope this solved the issue for you, but is almost certainly the case. Please let me know if we can further help.


#3

IF anyone’s interested

  1. To make the unlocking permanent, you must make at least one transfer to an Ethereum address not affiliated with FOAM. Until this transfer is made, any actions that bring your account back under the original PoU threshold will relock your tokens.

https://mapguide.foam.space/initial-proof-of-use-period/what-does-pou-not-complete-mean


#4

Hi @Ryan_foam ,

Piggybacking off of this thread… I am only about half way through the POU.

I have used crypto for many years and have experience using Ethereum. Yet, I have an issue when making FOAM transactions from my Ledger via Metamask. I have a queue of over 20 pending transactions that will not be submitted. I have tried processes for cancelling failed transactions like what can be done on DEX’s when the gas input was too low.

However, I can not seem to cancel or approve my pending FOAM transactions that I initiated. The gas may have been too low or it may have originally been a failed connection to the Ledger. Do you have any advice on how to troubleshoot this?

I have spent a few weeks looking into this issue!! :confused:

Thanks in advance!!


#5

Hi @beans1111sorry to hear you are having difficulty. I personally do not have experiencing using a ledger via Metamask.

As a first step try to reset your Metamask in the settings, this will clear pending transactions.

However, if a transaction is queued in Metamask you should be able to go to the first one and see “transaction taking too long? increase gas”. If you increase the gas on that one it should go through and you may need to do so for the remaining in the queue.

Alternatively you can transfer your tokens off of your ledger into the Metamask account by pairing the address https://mapguide.foam.space/initial-proof-of-use-period/pairing-a-secondary-non-metamask-address

Please let us know if your issues persist and we can step in to help.

Best,

Ryan


#6

Resetting Metamask in the setting worked!! Thank you for this easy fix to all of the pending transaction I had built up.

Good stuff @Ryan_foam!!


#7

Glad to hear! Let us know anything else.